bprdctl/bprdctl.spec
2020-10-21 09:50:28 +02:00

63 lines
1.1 KiB
RPMSpec

%define name bprdctl
%define version 1.0.6
%define major_version 1
%define minor_version 0
%define release_version 6
#%define target_lib libbprd
Summary: Silicom Bypass Control Utility
Name: %{name}
Version: %{version}
Release: %(uname -r | sed s/-/\./g).2
Vendor: Silicom, Ltd
License: GPL
Group: System Environment/Base
Source: bprdctl-%{version}.tar.gz
BuildRoot: /var/tmp/%{name}-buildroot
#BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
#BuildRequires: librdi
%description
This package contains Silicom Bypass Control Utility.
%prep
%setup -c -b 0
%build
cd ./bprdctl-%{version}/
make
%install
if [ -d /bin ]
then
mkdir -p $RPM_BUILD_ROOT/bin
echo "/bin/bprdctl" >> $RPM_BUILD_DIR/file.list.%{name}
fi
cd ./bprdctl-%{version}/
make install
install ./bprdctl $RPM_BUILD_ROOT/bin
%post
depmod -a > /dev/null 2> /dev/null
exit 0
%postun
depmod -a > /dev/null 2> /dev/null
exit 0
%clean
rm -rf $RPM_BUILD_ROOT $RPM_BUILD_DIR/file.list.%{name}
%files -f ../file.list.%{name}
%doc ./bprdctl-%{version}/readme.txt ./bprdctl-%{version}/release.txt
%changelog